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This section describes the new features in the version 6.16 of TopSolid’Wood. 

Design 

Curves and sketches 

Curve morphing 

A curve morphing function is now available in Curve > Other curves > Morphing, and allows you to automatically 
create a series of curves from several reference curves. 

 After creating several reference curves, select Curve > Other curves > Morphing.  

 

 Select the reference curves/sketches (at least 2 curves). 

 
 
Note: It is then possible to add or remove reference curves. 

 Set the Morphing options.  
 
Give priority to ends: When activated, this option keeps the curves located 
at the ends of the morphing when adding or removing a reference curve. 
For example, on the morphing here, the green resulting curve shows the 
difference between having this option enabled or disabled.  
 
Once the number of curves is modified, the result is the following: 
 

 
The green curve is still the second-to-last curve of the 
morphing. 

 

 
The green curve has not kept its position. 
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Interval mode: Specifies how the number of curves is calculated, either between each reference curve when the 
mode is enabled, or between the two curves at both ends. 
For example, a morphing created from 3 reference curves: 

 

 
6 curves are created between each reference curve. 

 
 
In the tree, a Stubs node appears under the Morphing 
section, indicating which curves delimit the stubs and 
resulting curves. 

 

 
6 curves are generated between both ends. 

 
 
In the tree, a Resulting curves node contains the curves 
generated by the morphing. 
 

 

 Set the number of resulting curves. 

Once the morphing is created, it is possible to modify the number of resulting curves, or add/remove reference 
curves. 

 Edit the morphing from the tree. 

 To add a reference curve, right-click on Reference curves > Insert, and click the curve(s) to be inserted. 

 To remove a reference curve, right-click on the curve line and select Extract. 

 To modify the number of resulting curves, double-click on the Number line. 
 
Note: Once the morphing is created, the Interval mode and Give priority to ends options cannot be modified. They 
can only be accessed when creating the morphing. 
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Connection 

It is now possible to connect several curves together using the Connection command. This command is very useful 
for creating a tool path, and then applying a machining on the generated curves. 

 Launch Curve > Other curves > Connection  

 Select the reference coordinate system. The best is to select the coordinate system on which curves have been 
drawn. 

 Then click the curves to be connected and validate with OK. 

 Set the options: 

- Keep curves orientation: Used to keep the orientation of the selected curves when creating the connection. 
If the option is set to NO, the orientation of some curves will be modified during the connection. 

- Link type: Used to select the connection link type: Line or Bspline.  

 
 
The connections created between the curves are lines.  
 

Origin curves: 
 

 

After connection: 

 
 

 
 
The Bspline mode creates curves to connect the selected curves. A loop length is to be entered; this value 
corresponds to the curve’s offset value. If this value is 0mm, new lines will be generated. It is also possible to use a Z 
minimum to prevent the connection from falling below a certain value. 

 
 
Note: All these values can be modified after the creation of the connection. To do this, use the Modify function on 
one of the connections. 
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 Once the connections are created, operations can be applied to these curves (groove, user machining…). 

 

Cell 

When four open curves intersect each other, the new Cell function allows you to create a closed curve 
automatically. 

 After drawing open curves, select Curve > Other curves > Cell. 

 

Here are two green lines that are repeated on X and Y in order to 
generate a grid. 

 

 Select the four curves defining the cell in the order given above. 

The Projected mode can be used to project the generated cell onto a different coordinate system. 

After selecting the fourth curve, the cell is automatically created. 

 

 It is possible to stop the function or make a serial copy of this cell. 

 

 If the previously selected curves have been generated through repetition, the Automatic button automatically 
selects the curves in order. 

  



What’s new in TopSolid’Wood v6.16  TopSolid 2015 

6  Missler Software 

 In this example, the serial copy mode to be used is Interval. Then select Automatic and the cells will be 
repeated (blue curves). The tree displays the curves used to create the cells, as well as the generated stubs 
(cells). 

 
 
These curves can then be used to divide a part into several panels. 

 

Trimming 

It is now possible to trim a batch of curves by a closed curve using the Trimming command. 

 Launch Curve > Other curves > Trimming.  
 Select the trimming curve. 

 Select the curves to be trimmed. 

In the example below, the black curves will be trimmed by the six rectangular curves. 
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 If necessary, enter a gap between the trimming curve and the trimmed curves. 

 
 
Note: It is not required to specify an extrusion direction; this option is only useful if the extrusion direction is not 
perpendicular to the trimming curve’s plane. 
Still using the same example, the curves generated by the trimmings are shown in green. A gap has also been added. 

 

Once the trimming is created, some parameters can be modified. 

 Edit one of the resulting curves from the tree. 

 To add a curve to be trimmed, right-click > Insert on Curves. 

 A double-click on the Gap line modifies the gap value. 
 

The stubs correspond to each trimmed curve. 
 
 
 
 
 

Part partition 

The new Partition function command makes it possible, from an original part and closed curves, to automatically 
create the resulting parts. 

 

 Launch Shape > Other shapes > Partition.  

 Select the part for the partition. 
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 Select closed curves to partition the part. 

Note: Here it is possible to select one or more sketches. 
The partition will be performed on the closed curves of 
sketches. 

 

 Once all curves are selected, validate with OK. 

Note: It is then possible to add or remove curves from the 
partition. 

 

 Enter a gap between each partitioned part, and then validate with OK. 

 
 
Note: As with the extrusion function, the Extrusion direction option modifies the partition direction of the original 
part. By default, the extrusion direction is perpendicular to the curves. 

 

The partitioned shapes are then generated. 

 

 Edit the partitioned shapes from the tree. The Partitioned shape operation then contains: 

- The partitioned original shape. 
- The list of curves used for the partition. 

Note: It is possible to insert new curves by a right-click > Insert, and extract curves with a right-
click > Extract. 

- The extrusion direction. If the default extrusion direction is used, no direction is then 
displayed here, but it is possible to reconnect it. 

- The gap parameter between partitioned parts. 

-  The different parts generated as stubs, with the shape and the curve used to create 
it. 
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Define parts/sets 

Default matter overvaluation mode management 

The matter overvaluation modes for parts and panels are now managed in Tools > Options > TopSolid'Wood 

configuration > Define parts > Cutting-up.   

 Set the overvaluation mode for the definition of standard parts. 

 

Note: This overvaluation mode will only be used for new defined parts. 

 Set the overvaluation mode for the definition of panel supports. 

 

Note: This overvaluation mode will only be used for new supports defined when creating a panel on a non-defined 
part. 

Machining length always highest dimension 

A new option is available for machining and cut exports; it allows you to position the length axis of selected parts on 
their highest dimension without having to edit the part definition. 

Note: This setting is only available in the WoodWop, NCHops, Xilog and PanelCAM interfaces and Ardis XML exports. 
In addition, the option is only visible in multi-part export. 

 Start one of the compatible interfaces. 

 Choose Multi-parts. 

 Set the Length always highest dimension option to YES. 

 

Note: This setting does not affect the part definition; it is considered during export on an occasional basis only. 

Texture frame 

When the Add to sawing-up option is unchecked during the part definition, a frame must now be selected to 
properly orient the texture. 

 When defining a part, uncheck Add to sawing-up. 

 Select an existing frame or create a new frame by clicking directly on a face or using the Wizard button. 

 

Note: The frame is requested only if the part has grain orientation. 

Define multiple parts 

Various changes have been made to the Define multiple parts function to improve usability. 

This includes the possibility to expand or collapse the configuration section by clicking the  button. 
Material and texture modifications have also been enhanced. 
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Management of parts without sawing-up 

Parts without sawing-up are no longer grayed out in the Define multiple parts window and can therefore be 
configured. Parts with no sawing-up are displayed in yellow in the list of parts. 

Note: To avoid any errors, it is not possible to select a part with sawing-up and a part without sawing-up 
simultaneously. In addition, parts without sawing-up cannot be selected by criteria or by properties; they can only 
be selected manually. 

 

Management of assemblies and components 

Assemblies and components can now be configured in the Define multiple parts window. Like for parts without 
sawing-up, they are displayed in yellow in the list of parts. 

Note: Assemblies and components works the same way as parts without sawing-up; they cannot be selected at the 
same time as parts and cannot be selected by criteria or properties. 
In the example below, the Low cabinet assembly is displayed in yellow in the list, just like the Sink part which has no 
sawing-up. 

 
 
When one or more assemblies are selected, the Define assembly function’s dialog box is displayed. Single units are 
not configurable and are therefore grayed out. To be able to configure them, they must be set to Sub-assembly or 
Single unit. 
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In the example below, the Low cabinet assembly is selected. The definition of the assembly is displayed on the right 
side of the window. The Bottom + groove assembly has been defined as Single unit, it is therefore grayed out. 

 
 

Elements that make up the single units can be displayed in the list of parts in order to be configured. 

 Select Tools > Options > TopSolid’Wood configuration > Configurators. It is then possible to choose in which 
functions the constituents of the single units will appear. 

 Check Define multiple parts.  

Still in the same example, the part belonging to the Bottom + groove single unit appears in the list of parts of the 
Define multiple parts window and can be configured. 
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Define set 

Now, when the Define set function is launched in a document with only one defined part, a question appears. 

 
 
If the answer is set to YES, the Define part dialog box opens automatically and the definition of the part contained in 
the set is modified. 

When a single unit is displayed in a part selection dialog box (Define multiple parts, Configurators…), it is possible to 
display its constituent part(s). This setting needs to be made for each function. 

 Go to Tools > Options > TopSolid’Wood configuration > Configurators.  

 Check the functions in which the constituents of the single units must be displayed. 

 

Improved sketch display 

The display of sketches from the tree has been improved to make their comprehension easier. 
The editing of a sketch now displays: 

- The sketch creation coordinate system. 
- The closed curves drawn in the sketch, with their associated dimensions and constraints. 
- The open curves drawn in the sketch, with their associated dimensions and constraints. 
- The sketch dimensions. 
- The sketch constraints. 
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If a dimension or a constraint is placed between two different curves, the 
element is then displayed in both curves as well as in the list of sketch 
dimensions/constraints. 
 
 
 
 
 
 
 

Ellipse in the sketch 

Ellipses can now be created in a sketch. 

 Start a new sketch.  

 Select the Ellipse function.  
 
It is possible to draw two different types of ellipses: 

- With a center point. 

 

- With two focuses. 
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Ellipse with a center point 

 Select the center point of the ellipse to be drawn. 

- Then select a point towards X and a point towards Y to generate the ellipse. 
- Set a radius or a diameter on X, and then on Y to generate a dimensioned ellipse. 

 
Ellipse with two focuses 

 Select the 2 focus option. 

 Select the first and second focus. 

 Then select a passing point to generate the ellipse. 
 
The Center point or 2 focus ellipses can be dimensioned by: 

- Their center point or their two focuses. 
- Their two control points on X. 
- Their two control points on Y. 

 
 
 

Constrained block 

Given section 

It is now possible to create constrained blocks using a given section. This section is then saved to be reused. 

 Launch the Constrained block command.  

 Set Section = YES. 

 Enter the section’s thickness and width values. 

The new created section appears in the drop-down list. 

 

Note: The Share thickness  function allows you to retrieve the dimensions of an existing constrained block. 
Then, when the dimension of one of the two blocks will be modified, the other block will be automatically modified. 

 Choose the planes of the constrained block and finish creating it. 

The previously created section then appears in the drop-down list. It is possible to have several predefined sections. 
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Note: After a section has been created, it is automatically added to the list. To remove sections from the list, you 
need to open the top.cfg file, and then delete the lines corresponding to the sections. These lines begin with 
D_SH_CBLOCK_SECTION, followed by the section dimension in meters. 

 

Automatic assembly 

It is now possible to automatically assemble the constrained blocks using automatic assembly rules. Assemblies are 
created after completion of the function, after distribution. 
It is possible to use predefined assembly rules or manually select an assembly to be applied. 

 To use a predefined rule, assembly rules for constrained block must be declared first in Tools > Options. 

 Go to Tools > Options > TopSolid’Wood configuration > Automatic assembly, and click the Constrained block 
tab. 

 Create a new rule using the Add rule button. 

 Rename the rule by double-clicking in the created line’s Name column. 

 Then define the rule to be applied to each face of the constrained block. The rules available in the drop-down 
lists of each face are existing automatic assembly rules. 

Note: An animated image allows the four faces to be identified. 
  



What’s new in TopSolid’Wood v6.16  TopSolid 2015 

16  Missler Software 

 
 
Once in the assembly, these rules can be used after completion of the Constrained block function. These assembly 
functions are mainly used for in-place design. 

 Create a constrained block. 

Note: When creating the constrained block, the Invert direction button is now available in the second question. 

 On completion of the function, choose the rule to be used in the drop-down list. 

 

Labels appear on the faces used by the selected rule. 

  



TopSolid 2015  What’s new in TopSolid’Wood v6.16 

Missler Software  17 

Note: These labels consist of two areas: 

- The first area corresponds to the general rule applied to all faces. The assembly rules for constrained block 
are available. 

- The second area allows you to modify the applied rule locally; only the face identified by the label will be 
modified. Only the automatic assembly rules are available. 

A double-click on one of these areas opens a drop-down list to modify the rule used. To close the drop-down list, 

click the red cross icon . 

 
 
It is also possible to manually select the rules to apply to each face. 

 Select Manual in the drop-down list 

 Define the rule to be applied to each face.  

Rules can be created directly from labels. 

 Choose a rule in the drop-down list at the end of the function. 

 Double-click in the first area of one of the labels. 

 Select Add rule. 

A creation dialog box opens. This dialog box works similarly to the rule creation dialog box in Tools > Options. 

Note: The rule will be added to those created in Tools > Options > TopSolid’Wood configuration > Automatic 
assembly > Constrained block. 

 

 Once the rules are selected, validate with OK. 

Arrows appear, allowing you to change the direction of components. They work the same way as those displayed in 
the Automatic assembly function. 

 Finish creating the components with OK. 
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Note: After validating the creation of the constrained block and the components, the created part is automatically 
defined in order to perform the component processes. If parts in contact with the components are not defined, no 
process is created. However, the machining will be automatically generated after the part definition. 

Automatic deactivation of cut parts 

If after operating a part (trimming, subtraction, pocket, etc.) there is no material left, this part is now automatically 
deactivated. It will no longer be visible when projecting it into draft, bill of material, and in higher level sub-
assemblies. 
 
For example, a panel with four edges on which a sawing operation 
must be performed (according to the black line). In this case, the 
edge does not intersect the curve, but it must be disabled during 
the operation. 
 
Note: This applies to serial sets and panels. 

 Once the operation is completed, the edge is deactivated and the Deactivated by process information appears 
on the edge line. 
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Other CAD improvements 

- Now, when removing an operation, you are asked whether tools are to be deleted, made visible or hidden. 
- When creating an extrusion, several curves can be selected one after the other without using the Selection 

function. 
- The Move function can be used on a relative point; the coordinate system on which the point was created is 

automatically activated. 
- Using the Modify function on a point modifies its position on the X,Y and Z axes thanks to the + and – 

buttons. 
- A text can now be used as a reference for a tabulated parameter. 
- A distribution can now be defined as a driver by right-clicking on the distribution line > Define driver. 
- A stop can now be turned into a main stop with a right-click > Main stop. 
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Coordinate system creation wizard 

The new coordinate system wizard allows you to directly select the elements to be used to create the coordinate 
system without having to select the type of coordinate system first. 
Based on the selected elements, the appropriate coordinate system is then created. If the selected elements allow 
you to create two different coordinate systems, you will need to choose the coordinate system to be kept. 

 Start Tools > Coordinate system.  

 Set Wizard = Yes. 
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Assemblies 

Improved assembly functions 

The Dowel assembly, Screw, Len and Assembly kit functions now use the automatic processes of components. 
For example, this allows you to assemble more than two parts, while ensuring that the processes will be performed. 
Before, these functions could only operate two parts. 

Non-symmetrical kit 

The assembly kit definition function has been improved. This now makes it possible to define non-symmetrical 
assembly kits. This feature also manages the notion of thickness which was necessary for screws.  
This new definition of the assembly kit can contain two distinct portions: the main portion and the opposite portion. 
Each portion includes a set giving the elements to be included, a key coordinate system and a set of tools. 

 In a new document, draw three parts in contact, representing the two insertion possibilities. 

 Next assemble them using standard components. 

In this example, the two green parts correspond to the parts to be assembled. The kit includes a screw, a dowel and 
a cam. As the kit is not symmetrical, the gray part will be used to define the opposite portion; this opposite portion 
must also be assembled by components. 

 

 Select Wood > Define > Define assembly kit.  

 Choose Advanced assembly kit. 

 Select the key coordinate system. 

In the example, the key coordinate system is the coordinate system that is centered on the part thickness. 

 Select the length parameter, the centring thickness parameter and the thickness parameter of the part in 
contact. 

These three parameters are shown in the following example. 
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Once all parameters are provided, the first portion of the kit is created. Elements that make up the assembly kit 
appear in the construction tree. The Tools set node contains elements only if tools have been defined in the 
document. 
In this example, tools are inherited from components and therefore do not appear in the list. 

 

 If the kit is symmetrical, choose STOP. Otherwise, choose Define opposite part. 

 Select the key coordinate system of the opposite portion. 

In the example, the blue coordinate system has been created. 

Note: The key coordinate system of the opposite definition must be rotated by 180° along the X axis. 

 Select the components used in the opposite portion. 

 

The selected elements and the key coordinate system are then visible in the construction tree under Opposite part. 

Note: Elements can be added to the kit. To do this, right-click > Insert on the Set line of the main or opposite part. 

 

 Once completed, save the assembly kit in a standard library. 
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In an assembly, these kits can be inserted using the Include standard, Automatic assembly (if a rule using the kit has 
been created) or Assembly kit commands. 

 Next insert the assembly kit. As in previous versions, select a start face, and then define the centering direction. 

 Click all the faces on which to insert the kit. 
 

  

Management of multi-body extruded components 

Multi-body extruded components are now managed when creating miter or planar cuts. These extruded 
components are created and used in the same way as a simple extruded component. 

 Insert several shapes in the assembly when creating the component. 

 

 Include the component in an assembly, and then create the cuts. 
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Automatic material addition using component process 

It is now possible to automatically add material to a part by using an automatic tool process. 
 
Example of a cabinet with butt joint parts. 

  
 
 
Result after the parts have been automatically assembled using a kit with an automatic union process. 
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 Create the component. 
The example is an advanced assembly kit. 

 
 
 
 
 
 
 
 
 
 
 

 Create the shape for the union. Here, this is a shape 
extruded from a sketch (in purple). 

 
 
 
 
 
 
 

Note: The automatic union can be done in a process only if the union has a clash shape. In a simple process (drilling, 
pocket…), the tool’s clash shape facilitates and/or limits the search for parts to be operated. 
In the case of an automatic union, the clash shape can be used to determine the part with which the union must be 
done. 

 Create an extruded part (red) which is in contact only with the blue part. 

 
 

 

 Make the part union using the Shape > Unite  
command, and select the martyr part (blue) as 
Shape(s) to modify and the part to be united (in 
purple) as Tool shape(s) to use. 
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 Create a tool in the component using the Assembly > Define component > Define tool command. 
The tool must be created in Operation type = Local operation on shapes mode. 

 
 

 When selecting the local operation to insert in tool, 
select one of the united shape’s faces. 

 
 
 
 
 
 

Note: The union is now declared as a tool. However, it can be used only if the clash shape is declared. 

 From the construction tree, edit the tool set. 

 On the union line, right-click > Define tool. 

 Select Define clash shape.  

 
 
 
 
 

 Select the previously extruded part as the clash shape. 
 
 
 
 
Note: In the component tools, it is possible to create a tool which will subsequently operate the united shape. 
In the tool set, this operation must be located under the union process. 
 
Preview of the martyr part 
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Order of the component tools 

 

Result in the assembly 

 
 
Note: The automatic union in a component process, just like the manual union, is not allowed on panel entities. 

Constrained positioning 

3D labels are now displayed when creating or modifying the constrained positioning. 

 Insert a component in an assembly. 

When a positioning constraint is created, a label appears, pointing to the constrained face. 

 

After creating the constraint, the constraint labels already created are displayed. 

These labels are divided into four areas : 

- The first area is the icon of the created constraint (plane on plane, axis on axis…). When the cursor is 
positioned on this icon, a graphic echo shows the constrained elements. 

- The second area can be used to modify the distance between the two constrained elements. For example, in 
the case of a plane on plane constraint, this allows you to move the planes away from each other or bring 
them closer. Clicking in these areas allows you to enter the distance manually, use the + or – buttons, or 
move the cursor. Before using the + or – buttons or the cursor, a step must be entered. 

 

Note: On some constraints, it is not possible to enter an offset value, like for an axis on axis constraint for example. 
This area therefore does not exist. 

- The third icon inverts the constraint. 
- The fourth icon deletes the constraint. 
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Operation priority: Component positioning 

The Operations priority function now provides an additional positioning that allows you to assign priorities to the 
operations generated by the component, while respecting the positioning when it is assembled on different faces of 
a part. 
Below is a handle component that generates a pocket and a rabbet when it is inserted. 

 

 In the Operations priority function, place the operations that will be generated by the component in 
Component positioning. 

 

When using this component in an assembly, the operations will be exported according to the priorities defined in 
the component model, while taking into account the face on which it is positioned. 

In the example below, the handle is inserted on two opposite faces. 
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During export, the operations will be generated in the order defined in the model and on two different faces. 

 

Panel grain orientation 

It is now possible to drive the grain orientation of a panel’s supports and laminates by right-clicking > Drive grain 
orientation on the support or a laminate of the panel entity. The driver parameter is then displayed in the tree 
under the concerned element. 

 

If the grain orientation of laminates must always follow the support’s grain orientation, the Same grain orientation 
for support and laminates option must be checked in the panel’s Advanced options. 
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Settings 

Driver block in Dimensions mode 

Driver blocks can now be inserted in Dimensions mode. This makes it possible to specify the block’s dimensions, and 
then position it using constraints. These dimensions can be driven by a catalog or manually entered during inclusion. 
 
Note: The driver block is not compatible with key points/coordinate systems; only the constrained positioning can 
be used. 
 
When creating the driver block, a new default housing mode is available. 
 
The three dimensions of the driver block can be driven by a catalog. To do this, once the driver block is created, do 
the following: 

 Select Assembly > Define component > Edit catalog header and choose All parameters and texts. 

 An Excel file opens. Enter the values for the X, Y and Z 
dimensions of the driver block. 

 Save the file. 
 

 In an assembly, select the code to be used when including the component.  

By default, the X, Y and Z values of the driver block match the values you specified in the catalog. 
Still using the same catalog, the first code has been selected during the inclusion. The component dimensions are as 
follows. 

 
 

 
 

 
 
Note: These dimensions correspond to the created catalog. However, these values are not fixed. It is possible to 
enter different values from those in the component catalog. 

Predefined values can also be set for each of the parameters.  

 Edit the driver block from the tree. 

 Double-click one of the three lines corresponding to the block’s dimensions. 
 

 Click on Predefined values.  

 

 In the dialog box, enter the different possible values. If the Only 
those values option is checked, a drop-down list will appear during 
insertion, and it will not be possible to enter a value manually. 
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Wood machinings 

User machining on simplified panels 

User machinings can now be created on simplified panels. 

Calibration deactivation option 

User machinings can now be defined as calibration or milling operations. 

 Create a part and define it. 

 Launch Wood > User machining.  

 Click the reference face, and then the tool path. 

 Select the operation type: Calibration or Milling. 

 
 
During a machining export, the Calibration user machining is subject to the calibration rules: proper positioning for 
part definition, deactivation of automatic calibration. 
However, a Milling user machining is considered as a pure milling operation. 
 
Note: The user machining created with the previous versions is automatically considered as a calibration, but its 
type can be modified. 

User machining orientation 

It is now possible to define the orientation of the tool used by a user machining. To do this, right-click > Define tool 
orientation on the operation. The given direction will then correspond to the tool axis. 

Note: This function has been developed mainly for TopSolid’WoodCam users. 

 
  



What’s new in TopSolid’Wood v6.16  TopSolid 2015 

32  Missler Software 

Configuration 

Customized contextual commands 

It is now possible to simplify the construction tree’s contextual menu. This provides an easily navigable menu and 
quick access to commonly used features. 
When right-clicking an assembly or a part, the More commands submenu has been added and lists the non-
common commands. 

 
 

 To define commands as common, right-click on a part or an assembly, and select 
More commands > Manage commands. 

 Check/Uncheck the functions. All unchecked functions will be listed in the More 
commands submenu. 

Note: Some commands cannot be defined as non-common and are therefore not 
listed: Modify, Delete, Analyze, Visible, Control, Zoom, Break associativity, Replace, 
Extract, Insert and Name. 

This setting is stored in a macro.cfg configuration file contained in the Config 
directory. 

Note: It is possible to manually place the macro.cfg file in the Group folder to have the same setting on several 
stations. If the macro.cfg file is located in both Group and Config folders, only the file in the Group folder will be 
loaded. 
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Definition of elements not to operate 

It is now possible to define standard components that should not be operated by automatic processes. For example, 
this prevents a dowel from operating a runner. 

 To define the standards not to operate, go to Tools > Options > Component > Components not to operate by 
automatic process. 

 
 

 Click on Add to define a standard not to operate. 
 A dialog box for selecting components appears. Select the component not to operate, 

and then validate. 
Note: It is possible to select the component directly or point to a folder or subfolder of the 
library. In this case, all components located in the folder will not be operated in 
assemblies. 

 Once the standard is added, it is possible to remove a component from the list using 
the Remove button. 

 Check or uncheck the option that sends a message if an automatic process attempts to operate the selected 
components. This only displays information in the alpha bar. In both cases, components are not operated. 

In the example below, the screw attempts to operate the handle declared as a component not to operate. A 
message is displayed in the alpha bar. 
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Assembly order for automatic numbering 

During automatic numbering, it is now possible to modify the order of components in the bill of material. This order 
can be modified using drag-and-drop directly from the construction tree.  

Note: Only the consecutive identical elements will be grouped together. 

 In an assembly, open the construction tree, and move the elements by drag-and-drop operation. 

 So that the order displayed in the tree is the same in the bill of material, open the .bom file of the bill of material 
using Notepad. 

 Modify the ORDER_BY paragraph. The syntax must be the following:  
 

ORDER_BY { 
  
  ORDER_BY=NULL 
} 

 
For example, an assembly with the following structure. As identical parts are not consecutive, they are not grouped 
together in the bill of material. 
 
 
 
 
 
 
 
 
 
 
Now if parts are reordered by drag-and-drop in the assembly and identical parts are consecutive, then these parts 
are grouped together in the bill of material and during numbering. 
 

  

Assembly: 

 

Bill of material: 

 
 

Reorganized assembly: 
 

 

Bill of material: 
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Material names in edge codification 

User matters and coatings are now properly translated during automatic generation of codifications. The syntax for 
displaying them has not changed; [<matter>] can be used to retrieve the matter and [<coating>] the coating. 

 Go to Tools > Options > TopSolid’Wood configuration > Edges/Laminates > Automatic codification of edges 
tab. 

 Specify a codification rule, and then generate the list of codifications. 

 
 

It is also possible to display the long name of matters and coatings in the codifications. This will show the category 
and the subcategory to which the matter or the coating belong. To do this, use [<matter long name>] and [<coating 
long name>]. 

For example, for the Beech matter used in the previous example, the long name will be Missler-Wood-Beech, since 
this matter is in the Missler category, and in the Wood subcategory. 

 

Note: Only user matters and coatings are compatible with this feature. 
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New BOM properties 

Properties that retrieve machining information have been added. These properties all have a YES or NO value. 
These new properties have been gathered into the TopSolid’Design - Cam information module. 

 

Wood Codification: Limited number of characters 

This setting is used by the WOO_CODIFICATION, WOO_CAM_FILE_NAME, WOO_NESTING_IDENTIFICATION and 
WOO_TREE_IDENTIFICATION properties. 
There are two ways to limit the properties, either using a correspondence table, or specifying the number of 
characters to be displayed. 
 
Correspondence table: It is defined in a configuration file named abbrev.cfg. This file can be placed in the Config 
and/or Group directory. If two configuration files are found, they are automatically concatenated. In this file, you 
need to define the correspondence between the value provided in TopSolid and the value displayed in the bill of 
material. Then, in the bill of material, use the syntax <WOO_CODIFICATION|$BOM property|Upper|Abbrev$>. 
 
For example, a part with the Top designation, and Top has to be replaced by TOP: 

 Open the file abbrev.cfg. 

 Write Top. 

 Press the Tab key. 

 Write the replacement value: TOP. 

 Once the correspondences are defined, open the .bom file of the bill of material used. 

 Enter the following syntax: <WOO_CODIFICATION|$DESIGNATION|Upper|Abbrev$>. 

 

 Display the bill of material of a file containing a part with a Top designation. Result: All designations using a text 
contained in the correspondence table are replaced. 
 

  
 
 

 

Number of characters to display: It is possible to limit the number of characters to be displayed. To do this, use the 
following syntax in the BOM file:   
<WOO_CODIFICATION|$BOM property|Upper|Trim(i,j,X)$> 
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In the Trim(i,j,X) property, the three parameters correspond to: 

- i: Number of the first character to be kept. If this number is negative, the counting is done from the end. 
- j: Number of characters to be kept. 
- X: Fill character if the property has less characters than j. 

 
Still using the previous example, the Right part has a reference P75608. In the bill of material, the first letter must 
not appear and only four characters must be displayed. The following syntax should therefore be used: 

 

Note: If both Abbrev and Trim are found in the syntax, the abbreviation will be trimmed. 
 
Result in the bill of material: The display of the reference starts at the second character and the next four characters 
are displayed. 

 

Note: As the Left and Bottom parts have a reference with only two characters, this reference is completed by the fill 
character (X in the example). 

Improved custom filters 

Reminder: Creation of a multi-criteria filter 

Prior to addressing the various improvements made to the multi-criteria filters, here is a reminder of the procedures 
that need to be followed to create a filter. 

 Open the multi-criteria filters in Tools > Options > Multi criteria filter.  

 Double-click an empty line in the Name field and rename the filter. 
 
For this example, a filter to select hardware parts will be created. 

 

 Define the property to be used to filter the parts. 
 
For this example, the property used is the part type. 
Therefore, you need to select the TopSolid’Design module 
and the PART TYPE defined function. 
 
Note: The selection of the function used by the filter is 
similar to the selection of a BOM property. You first need 
to choose the module where the property is located, and 
then select it in the drop-down list. 
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After that, the value type is requested. Three selections are available: CHARACTER STRING, INTEGER or REAL. 

 In this example, select CHARACTER STRING since the part type is a text. 
 
Note: The INTEGER and REAL types are reserved for numerical properties. 

 Define the operator to be used. 
 
Note: If the selected type is CHARACTER STRING, only 
the = , contain and start with operators can be used. 

 
 
 
 
Note: In the case of a filter on a part type, it is recommended that you choose the contain operator. In this way, the 
part will be selected even if it has several types. The = operator is more restrictive and will select the part only if it 
has the concerned type (only).  

 

 In the Value field, write the value to be compared. 
In this example, the value is Hardware since the parts to 
filter will have this type.  

 
Warning: The PART TYPE value is case sensitive. 
 
 

 Finish creating the filter by right-clicking the name line, and selecting 
Filter. 

 
Note: When creating the filter, four options are available:  

 

 
Used to refine the filter further. 
 
Example: A part A with the BLUM supplier and the Hardware type, 
and then a part B with the LMC supplier and the Hardware type. In 
the previously created filter, the Supplier property with the BLUM 
value is inserted using the Filter button. So when this filter is used, 
only parts with the Hardware type and the BLUM supplier will be 
filtered. In this example only, the part A is selected. 
 
 
 

 
Expands the filter possibilities.  
 
Still using the same example of the parts A and B, this time the 
first Supplier property is inserted with the Filter button; its value 
is BLUM. The second Supplier property with the LMC value is 
inserted using the Add button. When this filter is used, parts with 
the BLUM or LMC supplier will be selected. So in this example the 
parts A and B are selected. 
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Creates a copy of this filter by adding - Copy after the filter name; then you just need to 
modify it. 
 

 
Automatically filters the panel entities. 
 

 
Allows you to modify the filter after its creation. 

 To do this, you first need to specify the new property to be 
filtered, and then right-click on a property of the filter and 
select Modify. 

 

 
Deletes a property of the filter. 
 
 
 

Using filters in part selections 

Multi-criteria filters can now be used to select the parts. This option is available in the following dialog boxes: 
Matters configurator, Automatic assembly, Multi-draft, and all Machining and Cut exports. These filters must have 
been created first in Tools > Options > Multi criteria filter. 

 In the part selection dialog box, choose Select by filter, and then select the filter to be used in the drop-down 
list. 
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Improved management of materials and textures 

A new material definition window has been created. Materials and textures can now be set in the same window. 
This window works similarly as in the previous version. 

Note: The Attributes > Textures function is now only used to import textures; textures can be directly set 
(reflection, transparency…) using the Attributes > Matters > Manage materials function in the Texture param. and 
Image data tabs.  
 
A new material file replacing the top.mat file has also been created: topmaterials.xml. The materials of the previous 
version will therefore need to be migrated. 

 Launch Attributes > Matters. 

 Click the Migrate button. 

The materials are then automatically migrated to the new format and only the topmaterials.xml file will be used 
later. 

When creating or modifying a material or a texture, a preview is displayed on the right side of the window. 
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Improved imaging 

Light management 

In order to be compatible with the RedWay module, lights have been redefined. It is now possible to: 

- Create OpenGL lights. 
- Create a Sky light that provides more options than those contained in the previous versions. 
- Import an IES light file. 

The existing Positional and Spot lights have simply been modified to be compatible with RedWay. 
 

 

New RedWay module 

A new RedWay imaging module has replaced LightWorks. The images generated are of better quality than in 
previous versions. 

 Select Image > Display. 

 Set the options. 

 Click in the graphics area. 
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Draft 

Multi-draft 

Scale factor calculation according to the border 

A new option in the multi-draft document calculates the view’s scale factor based on the dimension of the view in 
relation to its border. 
This provides a more adjusted scale factor and a view that is better positioned on paper. 

Note: The old scale factor calculation mode took account of the view dimension according to the document margins, 
title blocks, and other views. 

Free scale factor rounding 

The view scale factor calculation has been improved to allow the scale factor to be rounded as close as possible. 

Wood machining dimensions 

The automatic dimensions of grooves, rabbets and mouldings have been enhanced to display more information on 
these operations. In the File > Properties > TopSolid’Wood properties > Draft command, you can choose to project 
the notes and/or the dimensions for these three operations. The projected dimensions for each operations are the 
following: 

- Grooves: The width, depth and position dimensions and the entry and exit 
dimensions. 

- Rabbets: The width and depth dimensions and the entry and exit dimensions. 
- Mouldings: The entry and exit dimensions. 

 
The notes display the operation name and the name of the standard used as a tool. 
 
 
 
 
Below is an example of dimensions on a part with a groove. In the document properties, the Groove dimensions and 
Slot notes options have been checked. 

 

Note: The tool designation can be displayed in the note. To do this, the  option must be 
checked in File > Properties > TopSolid’Wood properties > Draft.  
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Component detailing projection 

Just as it was possible to project a schematic representation of components, it is now possible to project detailing 
elements.  
For example, this allows you to automatically project dimensions with the drafted assembly. 

Elements to be projected must first be defined in the component template. 

 On the main assembly (or on an alternative set), right-click > Define draft detailing. 

 Then set the viewing direction. Two modes are available depending on the behavior you want. 

-  

This mode allows you to project different elements according to the view orientation in the draft. You 
therefore need to specify the orientation in which detailing must be projected. 
 

In the example below, if dimensions only have to be projected in front view, the Z+ direction must be selected. 

Note: In order to select the correct orientation, it is best to use the compass orientation in the graphics area. 

 

 
 

Result in the draft document: 
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-   

This mode is used when no specific orientation is needed. 
 

Still using the same sample file, if this time the selected direction is Z, the result in the draft is the following. 

 
 

 
Note: In the case of a driver block component, it is 
recommended that you select an edge of the driver 
block. 
 
 
 
 
 
 
 

 Next, select the elements to be projected in the draft. 

Note: It is possible to select curves, dimensions, shapes, texts. 
 
 
 
 

 Once the selection is completed, you can give a name and a designation to the draft detailing or finish by clicking 
on OK. 

Once created, a Draft detailings line is added under the concerned assembly. 
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 After defining the draft detailing in the component template document, include it in an assembly, and then 
create the draft of this assembly. 

 
This front is then assembled to form a complete drawer 
set. 
A formatted text that retrieves the reference of runners 
and a depth dimension are defined as draft detailings. 
Two detailings are created since the two elements are not 
visible in the same direction. 

 
 
 
 
 

The drawer set component is then included in an assembly.  
When creating the multi-draft document, the drawer set and the front are selected in order to generate a drawing 
of each of them. 

 

On the multi-draft result, both components are detailed. 

Once assembled, the drawer is projected in the draft. 

 To display the detailing elements in a draft, check the Components detailing projection option in: 

- Tools > Options > Projection parameters if you still want to project the component detailing. 

Note: This only applies to drafts that do not use any existing templates because, in that case, the setting made in 
File > Properties is taken into account. 
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- File > Properties > Projection parameters if you want to project the detailing elements only in a specific 
document (a draft template for example). 

- The creation or modification dialog box of a view if only a specific view must project the detailing elements. 

Note: The draft detailing in only inherited at the first assembly level.  

Machining export interfaces 

Export of shifted machining tool paths 

It is now possible to export in the TopSolid’Wood machining interfaces the shifted machining tool paths for the 
mouldings, the slots and the folds. 
This type of tool path can be configured for the following interfaces: 

- WoodWop 
- Xilog Plus 
- NC Hops 
- Ardis 
- EnRoute 

 
Note: For slots and folds, this setting will only be done on machinings performed with a mill tool. 

 Open the options from Tools > Options > TopSolid’Wood configuration. 

 Open the settings of the concerned interface from the Machining or 
Cutting off category (for Ardis). 

 From the Tool path section, configure the following: 

- Slot: Centred / Shifted 
- Fold: Centred / Shifted 
- Moulding: Centred / Shifted 
 

 
 

Note: The Centred tool path type is the export mode that is currently used and selected by default. 
 
EnRoute cut export 

For the export to EnRoute, the shifted tool paths are set via the following configuration words. 
 

Configuration word Value Effect 

ZX_ZWOO_CAM_DXF_FOLD_CENTRE 1 (by default) Export of the centered tool 
path for folds. 

0 Export of the shifted tool path. 

ZX_ZWOO_CAM_DXF_SLOT_CENTRE 1 (by default) Export of the centered tool 
path for slots. 

0 Export of the shifted tool path. 

ZX_ZWOO_CAM_DXF_MOULD_CENTRE 1 (by default) Export of the centered tool 
path for mouldings. 

0 Export of the shifted tool path. 
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- For a machining that goes through the part, on an edge or within the part, the shifted tool path is exported. 
 

 
 
- For a machining stopped in the part, the closed contour of the machining is exported. 

 

 
 
 

- For a machining which both is stopped in the part and goes through the part, the open contour of the 
machining is exported. 
 

 
 

- For a machining stopped on the part edge, the open contour of the machining is exported. 
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Moulding 

 
 

Result imported in Ardis. Result imported in WoodWop. 

 
 

 

 

 

Fold 

Part exported from TopSolid’Wood. 

 
 

Result imported in EnRoute. Result imported in NC Hops. 
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Slot 

Part exported from TopSolid’Wood. 

 
Result imported in Xilog. 
 

 

New Cyflex configuration for Xilog 

The Xilog export is now compatible with the Cyflex machine. 

 The machine for the export can be selected from Tools > Options > TopSolid’Wood configuration > Machining > 
Xilog Plus configuration. 

 Select SCM Cyflex from the Machine drop-down list. 

 
 
The following configuration words are also available for SCM Cyflex export. 
 

Configuration word Value Effect 
ZX_ZWOO_CAM_XXL_CYFLEX_POCKET_TOOL_NB 

 
By default 
140. 

Default tool number assigned 
to pockets. 

ZX_ZWOO_CAM_XXL_CYFLEX_SLOT_MILLING_TOOL_NB 

 
By default 
101. 

Default tool number assigned 
to slots/folds performed with a 
mill. 

ZX_ZWOO_CAM_XXL_CYFLEX_SLOT_SAW_TOOL_NB 
 

By default 
101. 

Default tool number assigned 
to slots/folds performed with a 
saw. 

ZX_ZWOO_CAM_XXL_CYFLEX_MOULDING_TOOL_NB 
 

By default 
101. 

Default tool number assigned 
to mouldings. 
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Update of machining faces 

When a project contains parts whose machining is in Optimized mode, it is possible, during exports to the 
machining interfaces and TopSolid’WoodCam, to update these machining faces according to the operations on the 
part. 

This update option is now available for the two sawing-up interfaces which also deal with machining operations: 
Ardis and EnRoute. 

Note: This option for updating machining faces is only available if at least one part of the assembly is in Optimized 
machining mode. 

 

Machining stop export 

The machining stops defined when defining a part are now exported to the machining interfaces. 

   
 

The name of the machining stop defined from Tools > Options > TopSolid’Wood configuration > Working stations 
configuration is exported to the interface. 
If a name and a designation are specified in the machining stop, the designation will be displayed in the part 
definition and the name will be exported. 
 
In interfaces where two machining files can be generated (WoodWop, Xilog, NCHops), only the name of the stop 
corresponding to the file machining positioning is exported. 
If two machining files are generated for the part, the machining stop name of the first positioning is exported in the 
first file and the machining stop name of the second positioning is exported in the second file. 

WoodWop 

Machining stops are exported as comments on the line #33 of the mpr file. 
 

First machining file Second machining file 

  
  



TopSolid 2015  What’s new in TopSolid’Wood v6.16 

Missler Software  51 

Xilog 

Machining stops are exported in the xxl file header. 

Note: The name of the exported machining stop must correspond to a work area in Xilog. Otherwise, the file may 
not be read in Xilog. 
Names of machining stops allowed in Xilog: A, B, C, D, AB, BA, CD, DC, AD, DA. 

NC Hops 

Machining stops are exported in a variable of the hop file. 

Note: As the hop file contains a new variable, the NC Hops import macros must be updated. 

The name of the variable in which the machining stop is exported depends on the language set in TopSolid’Wood. 

- French: _PosteTravail 
- English: _WorkingStation 
- German: _Arbeitsstation 

 
This variable can then be used in NC Hops like any 
other variable. The new macros allow the 
machining stop to be displayed in brackets after the 
part material. 
 
 
 
 
 

Ardis 

As all machinings of all parts are sent to the same Ardis file, the two machining stops of each part are contained in 
the generated xml file. Both of these are exported in the columns: 

- First stop: PartCNCOriginMain - Origin main 
- Second stop: PartCNCOriginSecond - Origin secondary 

 
To ensure that machining stops can be properly read in Ardis, the TopSolid’Wood stop names and designations 
must be set as follows: 

 

TopSolid’Wood stop name TopSolid’Wood stop designation Reading in Ardis 

0 Undefined Undefined 

1 Left Left 

2 Right Right 

3 Left front Left front 

4 Right front Right front 

5 Left rear Left rear 

6 Right rear Right rear 

Other value / Undefined 

  



What’s new in TopSolid’Wood v6.16  TopSolid 2015 

52  Missler Software 

Configuration of stops in the options: 

 

Stop selection from the part definition: 

 

Result in Ardis: 
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What’s new in TopSolid’Progress v6.16 
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This section describes the new features in the version 6.16 of TopSolid’Progress. 

Part preparation 

Analyze unstamping results  

A new type of analysis is now available: the Forming Limit Diagram (or FLD). 
It takes into account the data resulting from the analysis of minor strains, major strains and safety zones, and 
displays them as a diagram of points. 
The abscissa axis represents the minor strains and the ordinate axis represents the major strains. 
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The various colored curves identify the areas of characteristic behaviors where the analysis points (the part’s 
meshing nodes) are displayed in the corresponding color. 
This diagram allows you to quickly evaluate the part's formability by immediately viewing the nature and 
distribution of the behaviors the part will be subjected to during the forming process. 

In addition, a new option allows you to capture images when editing the currently viewed analysis. It is possible to 
adjust the capture settings (size, resolution) and specify whether the scale is to be embedded in the image. Once 
captured, a preview of the resulting image is provided. 

 

When validated, the image is automatically saved in *.jpg format in a subdirectory of the part’s directory. 
These images are then available to users in the report creation stage of the Nesting command (see next chapter). 

Nesting  

Many improvements have been made to this command. 
The overall dialog has been reorganized and includes a new tab for editing the nesting results. 
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Data tab 

Two new nesting types have been added: 

- Minimum circle 
- With symmetric part (horizontal) 

 

The Minimum circle nesting type computes the part’s minimum bounding circle and applies the step and strip width 
values resulting from this computation. 
The With symmetric part (horizontal) nesting type computes, for each requested part orientation, the pattern of 
the part and its symmetric part offset by the minimum possible distance in the strip progressive direction. From this 
pattern, it applies the step and strip width values resulting from the computation. 

A new Accurate gaps option allows you to compute the nesting results by fully respecting the requested gaps 
between parts (based on the precision specified by the user). 
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This option uses a new calculation mode for the distances between parts, based on the parallelization of the part’s 
exact external profile (the polygonized profile is used when this option is not selected), and ensures accurate steps, 
strip width and part positions during calculations and drafting. 
When this option is activated, it is also possible to specify an increment angle value less than 1°. 

In the Gaps section, two new parameters have been added: Vertical gap in pattern and Horizontal shift of top part 
in pattern. 

 

These two parameters are only active if the Accurate gaps option and the With rotated part and/or With symmetric 
part nesting types are required. 
The Vertical gap in pattern parameter allows you to define the gap between the top and bottom parts that make up 
the pattern. This gap may therefore be different from the gap between parts which is used to calculate the position 
of parts in the strip progressive direction. 

 
The Horizontal shift of top part in pattern parameter allows you to specify a translation for positioning the top part 
of the pattern which will be used for the nesting computation.  
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In the Strip section, the material data are now initialized from the part used to generate the unfolding. However, it is 
always possible to define and impose these data manually. 

 

Edition of the results tab 

It is now possible to set a given step between parts thanks to the Imposed step option. It allows the use of a 
rounded step value rather than that calculated by the application. 

 
 
In the lower area of the dialog box, you can now select the images to be inserted in the report in Draft format. The 
available images result from the captures that can be taken in the Analyze unstamping results command (see 
previous chapter). The selected images will be inserted in the Draft document, instead of the bitmaps inserted in the 
selected template (Tools > Bitmap in the Draft document). In the template, these bitmaps must be identified using 
the Progress die > Nesting report configuration command of the Draft document. You only need to select each 
bitmap and specify an index value to use in the list of selected bitmaps. A default Draft template document for the 
report is provided (in English).  
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In the Draft document templates of the nesting reports, it is now possible to get the cutting length and cutting 
strength parameter values. 
These values can be accessed using the Progress die > Nesting report configuration command of the Draft 
document. 

Bend division  

The bend division line can now be positioned by specifying a value corresponding to the flat bend length, and taking 
into account the bending allowance computation rules. 
After selecting the new division mode = GIVEN LENGTH ON FLAT BEND and specifying the Distance on flat bend 
value, the system will ask for the bending allowance computation method to use in order to calculate the portion of 
angle this length will match on the bended part. 
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Body management  

In the DIVIDE mode, the smooth edges generated by the trimming of bodies are now kept. 

In the MOVE BODIES mode, a new POSITION BODY submode has been added. 
This new positioning mode is particularly useful for repositioning bodies resulting from a flange unfold operation 
whose some subareas have been ignored and left in place (see next chapter). 

Flange unfold  

It is now possible to define a sub-area to be ignored within the area to unfold. The geometries of this part’s sub-area 
will be left in place. It will be up to the user to reposition this isolated body manually on the unfolded part. 
A typical use of this configuration concerns the small bended tabs hooked to a forming that separates them from 
the main body of the part. 
For example, for the part shown below, the purple area must be treated by bending before the flange unfold 
operation is performed on the green area. 

 

With this new functionality, the flange unfold operation can be done on the green area while leaving the purple area 
in its original position in order to obtain the following result. 
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Thanks to the Bodies management > Move bodies > Position body command, it is then easier to reposition the 
body that was left in place. 

 
Using the same command in MERGE mode, these two bodies are merged into a single body. 
It is then possible to treat the bend using the Unbend for intermediate stage command. 

 

For more complex configurations, the definition of the transition area between the repositioned body and the body 
resulting from the flange unfold operation may be more complicated. It could be necessary to apply other design 
methods, including the surface modeling commands. 

Deep drawn wizard  

Ten lines are now available in the calculation form of the number of drawing steps. 
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Strip design 

Create strip  

In No strip of matter around part mode, it is now possible to fill the part’s internal holes by checking the Fill holes in 
part option. 

 

Punching  

Different loss treatment modes are now available. This makes it possible to keep the loss only on the station where 
the punching is performed, rather than keeping it on all stations. 

 

 

Example of the same punching operation performed with the Keep loss option on all stations (top) and with the new option on 
station only (bottom). 
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Force visualization  

The forces generated by the springs can now be displayed. 
For the computation, only the Progress standard components that are identified as springs are considered. 
For your information, the compression stroke used to calculate the forces is given when creating the spring 
component. 
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Die set 

Create die set  

It is now possible to use named parameters to specify the main dimensions of plates in the die set editing dialog 
box, or in the plate editing dialog box. Until now, it was only possible to use values to set these dimensions. 
The same applies to the other plate drivers in the plate editing dialog. 
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Consequently, in the Copy plate parameters command, now you will be asked if you want to COPY VALUES of 
parameters or if you want to LINK NAMED PARAMETERS. 

Include die set , Include standard die set  

In these two commands, if the template document of the die set contains parameters whose name is already used 
in the destination document, the user can now choose to duplicate these parameters (by giving them a new name 
since a default name is proposed), or merge them with the existing parameters of the destination document. 
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Components 

Components > Configuration , Components > Create , Component > Modify  

In the Component configuration command, a new Information tab allows you to associate an information text with 
each component. 

 
 
This text is shown in the component selection dialog box, as well as in the component modification dialog box. 
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Similarly, in component libraries, a PDF information file can be associated with each template. 

 

If such a file is found, it is possible to ask for it to be displayed in the component selection dialog box, and in the 
component modification dialog box by clicking the Information PDF button. 
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Component > Configuration , Driven clearances 

For calculating the Progress component processes, it is possible to request the associative calculation of clearances 
when the component dimensions are modified. 
This option can be activated individually, for each component template, via the dialog box for editing the Progress 
component configuration. 
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In addition, this option can be activated or deactivated for existing components via the dialog box for modifying the 
standard Progress components. 
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If this option is enabled, when changing the component dimensions, the clearances associated with the processes 
generated by the component will be recalculated based on the values given in the component’s configuration file. 

Progress die > Component definition > Stock definition  

The Stock definition command has been added to the Progress component definition commands available from a 
Design document. 
This command provides access to two new features. 
The DEFINE DEFAULT STOCK PROPERTIES option allows you to predefine the stock computation options for the 
current component. 

 
 
The SHAPES TO IGNORE IN STOCK COMPUTATIONS option allows you, for subassembly components, to identify the 
subcomponents that are to be ignored for the stock computation. 
In the example below, it is typically used to ignore the screws. 
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Punches and dies 

Cutting die  

When the base profile of a cutting die was circular, it was already possible to define the dimensions of the die’s 
second part as a diameter value. 

 

This feature is now available when creating cutting dies based on multiple selection of several circular profiles. 

  



TopSolid 2015  What’s new in TopSolid’Progress v6.16 

Missler Software  73 

Cutting punch  

When the base profile of a cutting punch was circular, it was already possible to set its final diameter rather than 
giving a clearance value (in order to obtain a rounded value for the punch dimension). 

 

This functionality is now available when creating cutting punches based on multiple selection of several circular 
profiles. 
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Miscellaneous 

Progress properties  

In the stock computation results, it is possible to still display the trailing zeros. 

Reproduce bom properties  

It is now possible to reproduce the Bom index information of template parts on the parts to be modified. 
When this option is checked, the copy of all the other BOM properties is automatically activated, considering that 
parts with the same BOM indexes must be identical. However, the copy can be manually disabled for each of the 
other selected properties. 

 

Edit > Duplicate 

The parts created with the Edit > Duplicate command are now automatically assigned to the set of their template 
part. 
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TopSolid’Viewer > Progress elements visualization  

In TopSolid’Viewer, a new Progress elements visualization dialog is now available. 
It is used to quickly show/hide parts by manual selection, or according to the Progress tooling set they belong. 

 

Draft 

Component index  

It is now possible to move a component index created with the Component index command after its creation by 
using the Modify command. 
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This section describes the new features in the version 6.16 of TopSolid’SheetMetal. 

General 

Direct access to the Tasks manager 

Purpose of the function 

The Tasks manager can now be accessed directly 
from the TopSolid main window. 

Triggering the function 

Access from File > New > SheetMetal > Tasks 
manager. 
 
 
 
 

Import menu 

Purpose of the function 

The functions that enable you to import multiple documents can be accessed directly from the system icon bar via a 
drop-down menu. 

 

Update status of Part documents 

Purpose of the function 

A new update status is available. 

Triggering the function 

When the Part document results from a TopSolid 7 unfolding, a new update status specifies whether the v7 
unfolding document no longer exists or it could not be found. 

 The PCH part is up to date with its v7 unfolding. 

 The v7 unfolding has been modified and the PCH part needs to be updated. 
 

 Unknown update status when the connection to TopSolid 7 is disabled . 
  

The v7 part could not be found. 
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Update status of Nest documents 

Purpose of the function 

New update status. 

Triggering the function 

The nesting update has been simplified. The context of updated functions (handwheel icon) has been removed. 
Now, when you want to update the nesting, you only need to click the traffic light icon. 
The referenced PCH parts are first updated with their respective TOP file, and then the nesting is updated. 

Traffic lights are now more readable. 

 Up to date nesting. 

 Some machinings of the nesting are not up to date (in relation to the machinings of referenced parts). 

 Geometries are not up to date. 

Importing multiple documents - Managing part families 

Purpose of the function 

Possibility of providing a family for a set of parts. 

Triggering the function 

During multi-document imports in which you are not asked to confirm the general parameters for each part, the 
General parameters dialog box appears only once for the set of documents. In this case, it is possible to specify the 
family which will be the same for all parts of the set. 
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Importing multiple documents - Closing PCH documents 

Purpose of the function 

Possibility of closing the PCH documents created when importing multiple documents TOP  PCH and 
DXF/IGES/DWG  TOP  PCH 

Triggering the function 

The setting is made in Tools > Options > Importation > Multidocs TOP  PCH 
Multidocs DXF/DWG/IGES 

 
TopSolid 7 import - Retrieving references 

Purpose of the function 

Possibility of retrieving the reference of the sheet metal part designed in TopSolid 7 during CAM import. 
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Triggering the function 

The reference is displayed in the document properties and available in the Tasks manager’s Reference field. 

 

Note: If the 3D sheet reference is not specified, but the unfolding reference is provided, the transferred value will be 
that of the unfolding. However, if both references are specified, the 3D sheet value takes priority. 

Since this reference may be modified in the PCH document’s properties, there is no associativity on this data over 
time (same for the designation). 

 

Displaying TopSolid 7 CAD parameters in the operator card 

Purpose of the function 

Possibility of displaying in the operator card, in the table describing the parts, the parameters defined in the v7 
unfolding document. 

Triggering the function 

 Define the parameter name as the column name. 

A sample table is available in the operator card: opcard_full_ex.dft. 
This table has the following designation: parts_params_info. 
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Example of table in the template operator card: 

 

Result: 

 
 
Note: These columns (whose names are customized to match the parameter names) can be added to the parts_info 
table. 
 

The same can be done in the complete order operator card. 

Import with basification 

Purpose of the function 

Basification of the Part document during import. 

Triggering the function 

- Single import 

 

- Import of multiple documents Top  PCH 

 

- Import of multiple documents DXF - IGES  TOP  PCH 
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This setting is available by default in Tools > Options. 

For single importation: 

 
 
When importing multi-documents TOP  PCH: 
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Automatic part lettering in multi-document import 

Purpose of the function 

Possibility of automatically lettering the part name when importing multiple documents TOP  PCH and 
DXF/DWG/IGES  TOP  PCH. 

Triggering the function 

The automatic lettering can be configured in Tools > Options in each multi-document import section. 

 

For each machine, you also need to configure whether the lettering is to be performed when creating the part 
during multi-document imports, as well as the font settings, the text height, the machining position and type 
(punching or laser lettering cutting). 
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Example: 

 

Note: There are also settings to perform automatic lettering during linked actions for part nesting. 
The settings for a given machine can be different. 

- If part lettering is requested during linked actions for nesting, it will not be performed if it has already been 
created on the Part document. The part lettering of the PCH document will be given priority. 

- If lettering is done using the Miscellaneous > Free contours > Lettering function and the Generate PartName 
as Text open is selected, this lettering is considered as part lettering, and in this case, the automatic lettering 
during linked actions for nesting will not be recreated for the part. 

Configuring waste sizes 

Purpose of the function 

Possibility of standardizing the waste sizes. 

Triggering the function 

Waste sizes can be configured in Tools > Options. 
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Two cumulative options are proposed: 

- Multiple value from minimum size. In the example above, the waste sizes can be 300mm, 500mm, 700mm, 
900mm, etc. 

- List of possible lengths (separated by ;). In the example above, the waste sizes can be 320mm and 450mm. 
 
If one or both boxes are checked, the system will adjust the waste size to the value closest to the set of values, while 
taking into account the minimum distance from the last part and the minimum waste size. 

Improved manual function 

Accessible from Cutting > Common > Rest cut. 

Two modes are available: 

- Automatic mode: The waste is calculated by taking full account of the distance from the last part. 
- Manual mode: A waste size is imposed. 

Once this function is launched, the system calculates the optimal waste size according to the standard sizes defined 
in Tools > Options and proposes the manual mode. 

 
 

Note: The same configurations are found in Tools > Options for punching machines. 

Mixed waste cuttings 

Purpose of the function 

Possibility of cutting rests automatically both vertically and horizontally on the same sheet. 

Triggering the function 

Configuration in Tools > Options for cutting and punching machines. 

The various choices are: 

- Horizontal 
- Vertical 
- Horizontal then Vertical 
- Vertical then Horizontal 
- In L in one go 
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For cutting machines, the menu of the Cutting rest feature has been modified. 

 
 
A new LeadInOut button allows you to configure the primings/exits, as well as maintain wastes with micro-tabs. 

 

Cutting examples: 

 

Punching example with automatic resizing: 
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Trapp door evacuation function - Tray number 

Purpose of the function 

Possibility of selecting the number of the evacuation tray. 

Triggering the function 

Trapp door evacuation menu. 

 

Pallet preview 

Purpose of the function 

Preview of the pallet selected in the drop-down list displayed on the wagon. 
This enables the pallets to be visually adapted to the parts to unload. 

Triggering the function 

 

Dynamic zoom can be done in the dialog box and the dialog box can also be cancelled. 
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Simplified visualization of the trapp door 

Purpose of the function 

The trapp door visualization can be simplified. 
Possibility of not viewing the evacuation trapezoid. 

Triggering the function 

Configuration in Tools > Options > Display options > Sequences. 

 Check the Simplified visualisation of the trapp door box. 

 
 

Full visualization      Simplified visualization 
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Visualization of doubled punches before simulation 

Purpose of the function 

Visualization of doubled punches. 

Triggering the function 

Visualization of doubled punches when displaying the simulation dialog box. 

 
 

 

Additional information in the operator card 

Purpose of the function 

Additional information in the operator card. 

Triggering the function 

In a nesting done from the Tasks manager, if parts not contained in the Tasks manager are added manually, the data 
of the operator card’s table such as the order, the customer, etc. are now provided with the values specified in the 
Part document’s properties. 

The same applies to nestings that are done outside the Tasks manager. 

This information is also displayed in the part operator card and in the complete order operator card. 
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Tasks manager 

Adding nestings to an order 

Purpose of the function 

This function allows you to add one or more nestings to an existing order without changing the nestings already 
done in the order. 

The new created nestings can be performed automatically or manually. 

Triggering the function 

 From the Tasks manager’s Orders done tab, activate the Add new nestings in order icon.  

 

Waste rotation in Tasks manager 

Purpose of the function 

Rotates the geometry of a waste. 

Triggering the function 

 Select a waste (whose preview is available) and use the two buttons . 

The geometry of the drawing file corresponding to the waste is rotated 90° or -90°. 
The preview is updated again. 
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TopSolid’Punch - Punching 

Notches decomposed into lines 

Purpose of the function 

Performing an automatic allocation while avoiding doubled punches. 

Triggering the function 

During automatic allocation, if notches are split into lines and lines are machined with a square or round tool, the 
system reduces the machining to avoid doubled punches where two lines intersect. 

 

Automatic allocation - Arc with two oblongs 

Purpose of the function 

A new feature allows you to place a tangential oblong on each side. 

Triggering the function 

The selected oblong has the same diameter as the arc and the shortest length of the tool library. 

A tool on point associative with the line is positioned provided that the line is greater than the tool. Otherwise, the 
oblong tool is positioned on the line. 

 

The arc then turned into an induced machining. 
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Configuration 

Accessible from Tools > Options > Punch > Automatic allocation > Adjustments. 

 

Activation in automatic allocation 

 

Activation in manual punching 

A function of the Punching menu can be used to perform this type of machining by clicking an arc.  
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Automatic allocation - Oblong groove 

Purpose of the function 

Half-oblong grooves are automatically recognized and the oblong tool with the relevant diameter is positioned. 

 

The machining is placed on the longest line if there is no collision, otherwise on the shortest line. The arc and the 
other completely covered line are placed as induced machinings. 

To disable the automatic recognition of oblong grooves, the following line must be added manually into the 
C:\Missler\Config\Topzpch.cfg file: 

ZPCHAFAUTO_HALF_OBLONG_GROOVE_WITH_OBLONG 0 

Punched rest cutting - Before or last 

Purpose of the function 

Possibility of configuring the machining order for the cut rest splitting in punching. 

Triggering the function 

Configuration in Tools > Options > Punch > Machining associated to the nest. 

 

You can also modify this information using the wrench on the splitting.  



TopSolid 2015  What’s new in TopSolid’SheetMetal v6.16 

Missler Software  95 

Applying the modified turret of a nesting to all the order’s nestings 

Purpose of the function 

If the current document is a nesting belonging to an order which was created from the Tasks manager, and the 
turret is in Manual tool put on mode, a new button then appears: Nests order turret change. 

This new feature can modify the turret of the current nesting document and apply this turret to all the order’s 
nestings. 

Triggering the function 

Requirements/Operating processes: 

A preliminary check is done (by opening each document of the order) on a station-by-station basis to make sure that 
all the turrets are identical. 

The dialog box with the turret picture allows you to change the place of the tool (for example). 

After validating the dialog box, the turret of the current document will be copied to all the order’s nestings with the 
usual checks that may make sequences for which the tool is no longer appropriate (wrong orientation) invalid. 
Messages are launched in the alpha bar, nesting by nesting. 

The simulation of each nesting is obsolete.  
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TopSolid’Cut - Cutting 

Free cuttings in the Part document 

Purpose of the function 

Possibility of performing free linear and circular cuttings in the Part document. 

Triggering the function 

Accessible from the Cutting menu > Cutting > Free linear path or Cutting menu > Cutting > Free circular path. 

 
 
 

  
The Connect auto button allows various lines to 
be connected in order to have a single cutting 
operation. 

  



TopSolid 2015  What’s new in TopSolid’SheetMetal v6.16 

Missler Software  97 

Internal skeletons 

Purpose of the function 

Creating a hole skeleton in the Part Document. 

Triggering the function 

Accessible from the Cutting menu > Cutting > Hole skeleton . 

This function creates lines inside the hole; these vertical and/or horizontal lines are spaced by a gap given in both 
directions. The starting point is one of the four corners of the hole’s enclosing box. 
If the hole already has a cutting allocation, it is possible to calculate the starting corner automatically to ensure that 
the last skeleton line is as close as possible to the priming on the contour. 

An Internal skeleton global parameters dialog box allows you to configure:  

- The minimum size of holes. 
- The gap between vertical lines and the gap between horizontal lines. 
- The priming length. 
- The retract value from the geometry. 
- The head position during link trajectories. 
- For full circles, you can choose whether the skeleton is to be cut continuously. 
- For rectangles, you can choose whether the skeleton is to be cut continuously and specify a sag value 

between lines. 

 

Question bar: 
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Example: 

 
 
If the hole is already cut in a cutting path, when creating the internal skeleton on the hole, trajectories are 
automatically inserted before the hole cutting. 
 

Example of continual cutting on the circle and the rectangle (in order to limit the primings): 
 

Using the wrench  on the internal skeleton displays the question bar and the parameters that can be adjusted 
locally on the given hole. 
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The internal skeleton cutting is associative to its geometry. If the support geometry changes, lines are recalculated, 
can be deleted, or new lines can be added. 
The starting corner may also vary depending on the new number of lines in order for the last line to be as close as 
possible to the priming. 

The configuration is done via a machine selection in Tools > Options. 

 

Note that the configuration of the skeleton cutting relating to the sheet can now be accessed here (function of the 

nesting menu Cutting > Common > Skeleton cut ). 

Internal hole wastes can be deleted via the icon . 

 

Note: The internal skeletons created in the Part document cannot be deleted in the nesting document.  

Moreover, the holes on which an internal skeleton has been created with the function are ignored by the sheet 

skeleton cutting function.  
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Moving lead in/lead out dynamically along contour 

Purpose of the function 

A new function can be used to move the lead in/lead out or the limitation point dynamically along a closed contour. 

Triggering the function 

 Select the  icon, and click a lead in, a lead out or a limitation point. 

Note: It is not possible to select a lead in/lead out on attach. 

If the lead in is at one end and the limitation point does not exist, a new limitation point will be automatically 
created for the dynamic movement. 

When the mouse cursor is located at one end of the segment, the lead in /lead out automatically moves to the next 
or previous segment. 

 Click the new selected position. 

The  button enables the lead in/lead out to be placed at the segment end that is closest to the 
mouse cursor. The limitation point is then automatically removed. 
 
There are restrictions on contours with micro-joints: 

The dynamic segment change is not possible here. 
The movement of the lead in/lead out will then be limited to the segment length if this segment does not have 
attach, or to the length limited to the attaches if the lead in to be moved is located between two attaches. 
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Multi-head machine 

Head changes 

Purpose of the function 

Possibility of choosing the head number on a given trajectory. 

Triggering the function 

Accessible from the Cutting menu > Cutting > Head choice on trajectory. 

A caption appears at the top left of the part indicating colors for each head available on the machine. 

 

 Select the head number from the drop-down menu, and click the trajectory to be modified, which will then be 
colored as the selected head. 

This function is available in the nesting document. Simultaneous head trajectories are displayed in black. 
Part cutting instances performed with different heads are shown in dark gray. 

In the nesting document, it is possible to overload on an instance the head number for all the instance’s trajectories. 

A button allows you to return to the part document’s head configuration (on a trajectory or an instance). 
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Note: During simulation, the cutting head changes to the referenced color. The information is also displayed in the 
player. 

 

Configuration 

Head colors can be redefined manually in the topzpchcut.cfg configuration file. 
 
# In multi-heads, when defining the head: identification colors of trajectories 
# Word     Head_N°  Color_Index 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 1 6 # ORANGE  Head N°1 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 2 26 # CYAN  Head N°2 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 3 18 # BROWN  Head N°3 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 4 8 # YELLOW  Head N°4 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 5 30 # MAGENTA Head N°5 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 6 10 # GREEN  Head N°6 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 7 4 # RED  Head N°7 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 8 27 # LIGHT CYAN Head N°8 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 9 14 # VIOLET  Head N°9 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 10 17 # LIGHT GRAY Head N°10 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD 0 2 # BLACK  Simultaneous multi-torches 
ZCUT_TRAJ_MULTI_HEADS_COLOUR_HEAD -2 3 # GRAY  Different head numbers in the instance 
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TopSolid’CutTubes - Tube cutting 

Tube import (TopSolid 7) 

Purpose of the function 

Possibility of importing in TopSolid’CutTubes tubes that were directly designed in TopSolid 7. 

Triggering the function 

In Tools > Options, the 3D TUBE machines must be defined and the import of v7 unfolded parts must be allowed. 

Example of a tube designed in TopSolid 7: 

 

Importing the tube in the TopSolid’Tube CAM 

 Use the New task  function. 

 

 Choose V7 TUBE EXPLORER. 
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The Project Explorer appears. Only checked-in parts are available. 

 

The tube is displayed on the screen to choose its position at 0° in the chuck. 

 
 

 Choose NO TRANSFORMATION. 
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 Select the machine. 

 

 Creation of the curves in the Part document. 

 

Note on v7 tube updates 

If a change is made in TopSolid 7, the light turns red to indicate that the PCH part is not up to date. However, it 
cannot be updated. The following message is displayed: 
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Improved common cutting nesting for round tubes 

In order for the tubes to better nest within each another, you can choose to nest the round tubes on 1.5 times the 
tube diameter in Tools > Options. 

 

Improved complex nesting for round tubes 

When the tube can rotate to 180°, it can be nested upside-down in common cuttings on 1.5 times the tube 
diameter. 

   



TopSolid 2015  What’s new in TopSolid’SheetMetal v6.16 

Missler Software  107 

 
 
A new option is available in the automatic path creation function and allows you to manage the tube common 
cuttings. 

 





TopSolid 2015  What’s new in TopSolid’WoodCam v6.16 

Missler Software  109 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

What’s new in TopSolid’WoodCam v6.16 
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This section describes the new features in the version 6.16 of TopSolid’WoodCam. 

Machine kinematics associative to 3D modeling 

In previous versions, a change in the machine geometry required the kinematics to be redefined. The machine 
kinematics is now associative to 3D modeling. This allows the position of any machine elements to be modified 
without redefining the kinematics. For old machine models, tool holders must be redefined. 

Radiusing and intersection between the closed curve’s last and first 
elements 

In the version 6.16, the path of a closed calibration is no longer extended by a tool radius; the starting point of the 
contouring operation is at the beginning of the path’s first element and the ending point is at the end of the last 
element. 

 
This path can be extended by using the lead in and lead out overlengths. 

Negative overlength value in contouring operations 

In all contouring derived operations (contouring, calibrating, sawing, groove, rabbet,…), it is possible to enter 
negative lead in and lead out overlengths. 
 
 
These negative values are necessarily defined in 
Along curvature mode. 
 
The Along curvature mode is automatically selected 
when validating a negative value in the input field by 
pressing the Tab key. 
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Tool rotation direction variable 

A new variable is now available in the processes and allows the rotation direction to be forced when selecting the 
tool. 
 
 
 
.ComplexForm.1.Form.ToolRotat = "R" -> The selected tool has a 
clockwise rotation. 
 
 
.ComplexForm.1.Form.ToolRotat = "L" -> The selected tool has a 
counterclockwise rotation. 
 
 
.ComplexForm.1.Form.ToolRotat = " " -> The selected tool has a 
clockwise or counterclockwise rotation according to the first 
matching tool.  
 
It is also possible to retrieve the value of this variable (for a 
formula or a comment). 
 
 

Contouring cut by another operation 

The concept developed in the version 6.14 for pockets is now available for contouring operations; a pocket crossed 
by another operation is now fully contoured. 

 
It is possible to choose in the process the type of topology to be used. 
 
 
Topo_mill_type = 0 -> Default topology (the machining will be 
performed only on a portion of the cut pocket). 
 

 
 
 
Topo_mill_type = 1 -> Topology given by the feature (the 
machining is performed as if no operation crossed the part). 
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Publishing of the maximum, minimum and optimized tool diameter 
values for pockets 

Three new variables have been added to the already existing pocketing list. They are available when editing the 
process parameters via the Keywords button. 
These variables provide the maximum, minimum and optimized diameters of the pocket profile. 
 

- Maximum Tool Diameter = Maximum circle diameter 
(different from zero) which is bitangent or tritangent to 
the sketch elements. 

 

 

- Minimum Tool Diameter = Minimum circle diameter 
(different from zero) which is bitangent or tritangent to 
the sketch elements. The result is zero if the pocket is not 
radiused. 

 

- Optimized Tool Diameter = Arithmetical mean of 
maximum and minimum values, i.e. (maximum diameter + 
minimum diameter)/2. 

 
The values of the above parameters can be accessed directly via the Info button available after the topological 
analysis of a face (if this face has a pocket topology). 
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Verification on several parts 

This new version allows several parts to be verified . This is very useful for verifying machinings on nested parts 
or on parts of a set. 

 
 

Clearance method in straight angles for engraving 

The feature that allowed clearance in straight angles of a multi-contouring in the version 6.15 is now available 

in the Engraving  function, and works the same way. 
 

 
 
Two clearance modes are available: On edge and On edge with retract. It is also possible to choose the kind of angle 
to be raised: Concave, Convex or both. 
 

The Clearance method in straight angles option can be accessed from the Main tab of the Engraving and Multi 

engraving  operations. 

Slope plunge and retract for engraving 

In the Engraving  function, the slope plunge and retract can now be configured. 

 

This works the same way as for the contouring. 
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Minimal tool length for all operations 

The Minimal tool length  option allows you to modify the chuck distance of tools for some or all operations in 

the Operations manager . 
It can be accessed by right-clicking the list of operations. 
 
It is also possible to calculate the minimal tool length considering the 
height of the stock and/or clamps. 
 
 
 

Retrieval of nested part’s properties 

When repositioning multi-nested parts, it is possible to define the name of the machining file via a BOM file which 
must include the WOO_CAM_FILE_NAME2 property. 
This BOM file must be declared in Tools > Options > Configuration > TopSolid'Wood configuration > File > Parts 
selection sorting > TopSolid'WoodCam export. 
 
If the WOO_CAM_FILE_NAME2 property is not defined in the BOM file used, or if no BOM file is declared, the 
designation of the turned-over part is taken into account as: Designation_turned-over.wod. 

Nesting turn-over method 

In multi mode, the turn-over method can be configured. This window is accessible by right-clicking the nesting, and 
then selecting Positioning and machining. 
 
In the red box below, three turn-over options are available: 

- Parts: Each part with operations positioned on faces other than those 
on top (side and bottom) is automatically turned over. 
 

- Nesting: The whole panel is turned over. 
 

- Without: No element is turned over. 

 
 

This way, the method can be configured for each nesting of the list of parts. 
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Shared reduced tool database (Group) 

When the reduced database is stored in Group, three new icons appear at the bottom right of the Tool 

manager . 

By default, the user cannot modify the tool database (no change in cutting conditions from the tool changer or the 
abacus, no change in materials, no saved prepared tool lists). 

 
 

These three icons will help you manage the changes made to the group database. 

- The Allow access to the database  icon gives users access to the reduced database for modification. The 
user ID is displayed in the upper section of the window for all the users connected to this database (the user 
1 can modify the database, the other users can only read it). 

- The Close access to database icon allows the database to be closed after modification and allows any 
users to load the new database (the user 1 closes the access to the database, all users can access the 
database again via the Allow access to database function). 

- The Update database  icon allows all users connected to this database to update it in the current session 
(all users can load the database modified by the user 1). 
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Sorting by tool unit in workshop documents 
In workshop documents, the tool tables are sorted by tool unit, and then by tool number. 
Spindles of old machine models must be initialized to make sure the tool units are properly sorted. 

 

ISO directory in multi-machining mode 
The "ISO" destination directory is no longer created by default in multi-machining mode. 
A default directory or path can be defined in Tools > Options > Routing configuration > Multi machining. 
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Operation parameters for post-processor 
The post-processor can enable the generation of operation parameters via a PDB_CONFIG. 
 
The list of parameters is created before the start of the tool path, since the number of parameters can be high. If the 
size of the event exceeds 1024 characters, the following parameters will be sent in a new PARAMETERS=OPER line. 
Each parameter contains a key and a value; they are available in the PDB with the prefix Db.Oper. 
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